intermittent call failures and One way audio.
Incident Report for CallTower
Resolved
Resolved: CallTower's Voice Engineers have implemented a solution to our routing in our NY Sansay location. We have confirmed with customers that the issue of one-way audio and intermittent call failures has been resolved.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted May 09, 2024 - 10:43 MDT
Investigating
Investigating: CallTower has initiated master case 01343366 after identifying an issue where users are experiencing intermittent call failures and no audio during inbound calls. Our Voice Engineers have been engaged, and we are actively working to resolve this issue urgently.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted May 09, 2024 - 10:02 MDT
This incident affected: Global SIP Trunk.